Backend updates
Resolved
Nov 03 at 03:39pm EST
Live testing successful. Thank you!
Affected services
Updated
Nov 03 at 03:34pm EST
Testing successful. Moving on to live testing now.
Affected services
Updated
Nov 03 at 03:29pm EST
Currently implemented enhanced security measures on Aquarius and Hydra. Testing now.
Affected services
Created
Nov 03 at 03:25pm EST
Improving backend security and general server performance.
Affected services